What’s Vulnerable › Vulnerabilities
CVE-2017-18520
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The democracy-poll plugin before 5.4 for WordPress has XSS via update_l10n in admin/class.DemAdminInit.php.
Affected products
- Wp-Kama Democracy Poll: before 5.4 — fixed in 5.4
How to fix
Upgrade to a fixed version: Wp-Kama Democracy Poll 5.4. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/democracy-poll/#developers
- https://www.pluginvulnerabilities.com/2017/02/22/cross-site-request-forgery-csrfcross-site-scripting-xss-vulnerability-in-democracy-poll/
- https://wordpress.org/plugins/democracy-poll/#developers
- https://www.pluginvulnerabilities.com/2017/02/22/cross-site-request-forgery-csrfcross-site-scripting-xss-vulnerability-in-democracy-poll/
Get alerted when CVE-2017-18520 or the next vulnerability affects your stack