What’s Vulnerable › Vulnerabilities
CVE-2017-18521
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-08-21 · updated 2026-06-17
- Weakness: CWE-352
Description
The democracy-poll plugin before 5.4 for WordPress has CSRF via wp-admin/options-general.php?page=democracy-poll&subpage=l10n.
Affected products
- Wp-Kama Democracy Poll: before 5.4 — fixed in 5.4
How to fix
Upgrade to a fixed version: Wp-Kama Democracy Poll 5.4. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/democracy-poll/#developers
- https://www.pluginvulnerabilities.com/2017/02/22/cross-site-request-forgery-csrfcross-site-scripting-xss-vulnerability-in-democracy-poll/
- https://wordpress.org/plugins/democracy-poll/#developers
- https://www.pluginvulnerabilities.com/2017/02/22/cross-site-request-forgery-csrfcross-site-scripting-xss-vulnerability-in-democracy-poll/
Get alerted when CVE-2017-18521 or the next vulnerability affects your stack