What’s Vulnerable › Vulnerabilities
CVE-2017-18540
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The weblibrarian plugin before 3.4.8.7 for WordPress has XSS via front-end short codes.
Affected products
- Deepwoods Software WebLibrarian: before 3.4.8.7 — fixed in 3.4.8.7
How to fix
Upgrade to a fixed version: Deepwoods Software WebLibrarian 3.4.8.7. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/weblibrarian/#developers
- https://wpvulndb.com/vulnerabilities/9725
- https://wordpress.org/plugins/weblibrarian/#developers
- https://wpvulndb.com/vulnerabilities/9725
Get alerted when CVE-2017-18540 or the next vulnerability affects your stack