What’s Vulnerable › Vulnerabilities
CVE-2017-18577
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-22 · updated 2026-06-17
- Weakness: CWE-79
Description
The mailchimp-for-wp plugin before 4.1.8 for WordPress has XSS via the return value of add_query_arg.
Affected products
- ibericode MC4WP: Mailchimp for WordPress: before 4.1.8 — fixed in 4.1.8
How to fix
Upgrade to a fixed version: ibericode MC4WP: Mailchimp for WordPress 4.1.8. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/mailchimp-for-wp/#developers
- https://wordpress.org/plugins/mailchimp-for-wp/#developers
Get alerted when CVE-2017-18577 or the next vulnerability affects your stack