What’s Vulnerable › Vulnerabilities
CVE-2017-18578
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-22 · updated 2026-06-17
- Weakness: CWE-79
Description
The crafty-social-buttons plugin before 1.5.8 for WordPress has XSS.
Affected products
- Crafty Social Buttons Project Crafty Social Buttons: before 1.5.8 — fixed in 1.5.8
How to fix
Upgrade to a fixed version: Crafty Social Buttons Project Crafty Social Buttons 1.5.8. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/crafty-social-buttons/#developers
- https://wordpress.org/plugins/crafty-social-buttons/#developers
Get alerted when CVE-2017-18578 or the next vulnerability affects your stack