What’s Vulnerable › Vulnerabilities
CVE-2017-18585
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-08-22 · updated 2026-06-17
- Weakness: CWE-22
Description
The posts-in-page plugin before 1.3.0 for WordPress has ic_add_posts template='../ directory traversal.
Affected products
- ivycat Posts In Page: before 1.3.0 — fixed in 1.3.0
How to fix
Upgrade to a fixed version: ivycat Posts In Page 1.3.0. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/posts-in-page/#developers
- https://www.pluginvulnerabilities.com/2017/02/13/authenticated-local-file-inclusion-lfi-vulnerability-in-posts-in-page/
- https://wordpress.org/plugins/posts-in-page/#developers
- https://www.pluginvulnerabilities.com/2017/02/13/authenticated-local-file-inclusion-lfi-vulnerability-in-posts-in-page/
Get alerted when CVE-2017-18585 or the next vulnerability affects your stack