What’s Vulnerable › Vulnerabilities
CVE-2017-18587
- Severity: medium (CVSS 5.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-26 · updated 2026-06-17
- Weakness: CWE-93
Description
An issue was discovered in the hyper crate before 0.9.18 for Rust. It mishandles newlines in headers.
Affected products
- hyperium hyper: before 0.9.18; from 0.10.0 before 0.10.2 — fixed in 0.10.2, 0.9.18
How to fix
Upgrade to a fixed version: hyperium hyper 0.10.2, 0.9.18. Check the vendor advisory for mitigations.
References
- https://rustsec.org/advisories/RUSTSEC-2017-0002.html
- https://rustsec.org/advisories/RUSTSEC-2017-0002.html
Get alerted when CVE-2017-18587 or the next vulnerability affects your stack