What’s Vulnerable › Vulnerabilities
CVE-2017-18609
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-09-10 · updated 2026-06-17
- Weakness: CWE-79
Description
The magic-fields plugin before 1.7.2 for WordPress has XSS via the custom-write-panel-id parameter.
Affected products
- Magicfields Magic Fields: before 1.7.2 — fixed in 1.7.2
How to fix
Upgrade to a fixed version: Magicfields Magic Fields 1.7.2. Check the vendor advisory for mitigations.
References
- https://sumofpwn.nl/advisory/2016/cross_site_scripting_in_magic_fields_1_wordpress_plugin.html
- https://wordpress.org/plugins/magic-fields/#developers
- https://sumofpwn.nl/advisory/2016/cross_site_scripting_in_magic_fields_1_wordpress_plugin.html
- https://wordpress.org/plugins/magic-fields/#developers
Get alerted when CVE-2017-18609 or the next vulnerability affects your stack