What’s Vulnerable › Vulnerabilities
CVE-2017-18703
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-24 · updated 2026-06-17
- Weakness: CWE-352
Description
Certain NETGEAR devices are affected by CSRF. This affects D1500 before 1.0.0.25, D500 before 1.0.0.25, D6100 before 1.0.0.55, D7000 before 1.0.1.50, D7800 before 1.0.1.28, EX6100v2 before 1.0.1.60, EX6150v2 before 1.0.1.60, JNR1010v2 before 1.1.0.46, JR6150 before 1.0.1.16, JWNR2010v5 before 1.1.0.46, PR2000 before 1.0.0.18, R6020 before 1.0.0.26, R6050 before 1.0.1.16, R6080 before 1.0.0.26, R6100 before 1.0.1.20, R6220 before 1.1.0.60, R7500 before 1.0.0.118, R7500v2 before 1.0.3.20, R7800 before 1.0.2.40, R9000 before 1.0.2.52, WN3000RPv3 before 1.0.2.50, WN3100RPv2 before 1.0.0.40, WNDR3700v5 before 1.1.0.48, WNDR4300v2 before 1.0.0.48, WNDR4500v3 before 1.0.0.48, WNR1000v4 before 1.1.0.46, WNR2000v5 before 1.0.0.62, WNR2020 before 1.1.0.46, and WNR2050 before 1.1.0.46.
Affected products
- NETGEAR D1500 Firmware: before 1.0.0.25 — fixed in 1.0.0.25
- NETGEAR D500 Firmware: before 1.0.0.25 — fixed in 1.0.0.25
- NETGEAR D6100 Firmware: before 1.0.0.55 — fixed in 1.0.0.55
- NETGEAR D7000 Firmware: before 1.0.1.50 — fixed in 1.0.1.50
- NETGEAR D7800 Firmware: before 1.0.1.28 — fixed in 1.0.1.28
- Netgear EX6100: before 1.0.1.60 — fixed in 1.0.1.60
- Netgear EX6150: before 1.0.1.60 — fixed in 1.0.1.60
- NETGEAR Jnr1010 Firmware: before 1.1.0.46 — fixed in 1.1.0.46
- NETGEAR JR6150: before 1.0.1.16 — fixed in 1.0.1.16
- NETGEAR Jwnr2010 Firmware: before 1.1.0.46 — fixed in 1.1.0.46
- NETGEAR Pr2000 Firmware: before 1.0.0.18 — fixed in 1.0.0.18
- NETGEAR R6020 Firmware: before 1.0.0.26 — fixed in 1.0.0.26
- NETGEAR R6050 Firmware: before 1.0.1.16 — fixed in 1.0.1.16
- NETGEAR R6080 Firmware: before 1.0.0.26 — fixed in 1.0.0.26
- NETGEAR R6100 Firmware: before 1.0.1.20 — fixed in 1.0.1.20
- NETGEAR R6220 Firmware: before 1.1.0.60 — fixed in 1.1.0.60
- NETGEAR R7500 Firmware: before 1.0.0.118; before 1.0.3.20 — fixed in 1.0.0.118, 1.0.3.20
- NETGEAR R7800 Firmware: before 1.0.2.40 — fixed in 1.0.2.40
- NETGEAR R9000 Firmware: before 1.0.2.52 — fixed in 1.0.2.52
- NETGEAR Wn3000Rp Firmware: before 1.0.2.50 — fixed in 1.0.2.50
- NETGEAR Wn3100Rp Firmware: before 1.0.0.40 — fixed in 1.0.0.40
- NETGEAR Wndr3700 Firmware: before 1.1.0.48 — fixed in 1.1.0.48
- NETGEAR Wndr4300 Firmware: before 1.0.0.48 — fixed in 1.0.0.48
- Netgear WNDR4500: before 1.1.0.48 — fixed in 1.1.0.48
- NETGEAR Wnr1000 Firmware: before 1.1.0.46 — fixed in 1.1.0.46
- NETGEAR Wnr2000 Firmware: before 1.0.0.62 — fixed in 1.0.0.62
- NETGEAR Wnr2020 Firmware: before 1.1.0.46 — fixed in 1.1.0.46
- NETGEAR Wnr2050 Firmware: before 1.1.0.46 — fixed in 1.1.0.46
How to fix
Upgrade to a fixed version: NETGEAR D1500 Firmware 1.0.0.25; NETGEAR D500 Firmware 1.0.0.25; NETGEAR D6100 Firmware 1.0.0.55; NETGEAR D7000 Firmware 1.0.1.50; NETGEAR D7800 Firmware 1.0.1.28; Netgear EX6100 1.0.1.60; Netgear EX6150 1.0.1.60; NETGEAR Jnr1010 Firmware 1.1.0.46; NETGEAR JR6150 1.0.1.16; NETGEAR Jwnr2010 Firmware 1.1.0.46; NETGEAR Pr2000 Firmware 1.0.0.18; NETGEAR R6020 Firmware 1.0.0.26. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000053199/Security-Advisory-for-Cross-Site-Request-Forgery-on-Some-Routers-Gateways-and-Extenders-PSV-2017-0736
- https://kb.netgear.com/000053199/Security-Advisory-for-Cross-Site-Request-Forgery-on-Some-Routers-Gateways-and-Extenders-PSV-2017-0736
Get alerted when CVE-2017-18703 or the next vulnerability affects your stack