What’s Vulnerable › Vulnerabilities
CVE-2017-18719
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-24 · updated 2026-06-17
- Weakness: CWE-787
Description
Certain NETGEAR devices are affected by a stack-based buffer overflow by an unauthenticated attacker. This affects D6200 before 1.1.00.24, R6020 before 1.1.00.26, R6080 before 1.1.00.26; R6700v2 before 1.1.0.42, R6800 before 1.1.0.42, and R6900v2 before 1.1.0.42.
Affected products
- NETGEAR D6200 Firmware: before 1.1.00.24 — fixed in 1.1.00.24
- NETGEAR R6020 Firmware: before 1.0.0.26 — fixed in 1.0.0.26
- NETGEAR R6080 Firmware: before 1.0.0.26 — fixed in 1.0.0.26
- NETGEAR R6700: before 1.1.0.42 — fixed in 1.1.0.42
- NETGEAR R6800 Firmware: before 1.1.0.42 — fixed in 1.1.0.42
- NETGEAR R6900 Firmware: before 1.1.0.42 — fixed in 1.1.0.42
How to fix
Upgrade to a fixed version: NETGEAR D6200 Firmware 1.1.00.24; NETGEAR R6020 Firmware 1.0.0.26; NETGEAR R6080 Firmware 1.0.0.26; NETGEAR R6700 1.1.0.42; NETGEAR R6800 Firmware 1.1.0.42; NETGEAR R6900 Firmware 1.1.0.42. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000052278/Security-Advisory-for-Pre-Authentication-Stack-Overflow-on-Routers-PSV-2017-2150
- https://kb.netgear.com/000052278/Security-Advisory-for-Pre-Authentication-Stack-Overflow-on-Routers-PSV-2017-2150
Get alerted when CVE-2017-18719 or the next vulnerability affects your stack