What’s Vulnerable › Vulnerabilities
CVE-2017-18731
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-24 · updated 2026-06-17
Description
Certain NETGEAR devices are affected by incorrect configuration of security settings. This affects R6100 before 1.0.1.16, R7500 before 1.0.0.112, R7500v2 before 1.0.3.20, R7800 before 1.0.2.36, and WNR2000v5 before 1.0.0.58.
Affected products
- NETGEAR R6100 Firmware: before 1.0.1.16 — fixed in 1.0.1.16
- NETGEAR R7500 Firmware: before 1.0.0.112; before 1.0.3.20 — fixed in 1.0.0.112, 1.0.3.20
- NETGEAR R7800 Firmware: before 1.0.2.36 — fixed in 1.0.2.36
- NETGEAR Wnr2500 Firmware: before 1.0.0.58 — fixed in 1.0.0.58
How to fix
Upgrade to a fixed version: NETGEAR R6100 Firmware 1.0.1.16; NETGEAR R7500 Firmware 1.0.0.112, 1.0.3.20; NETGEAR R7800 Firmware 1.0.2.36; NETGEAR Wnr2500 Firmware 1.0.0.58. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000051524/Security-Advisory-for-Security-Misconfiguration-on-Some-Routers-PSV-2016-0096
- https://kb.netgear.com/000051524/Security-Advisory-for-Security-Misconfiguration-on-Some-Routers-PSV-2016-0096
Get alerted when CVE-2017-18731 or the next vulnerability affects your stack