What’s Vulnerable › Vulnerabilities
CVE-2017-18734
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-23 · updated 2026-06-17
- Weakness: CWE-74
Description
Certain NETGEAR devices are affected by command injection by an unauthenticated attacker. This affects JNR1010v2 before 1.1.0.44, JR6150 before 1.0.1.10, JWNR2010v5 before 1.1.0.44, PR2000 before 1.0.0.18, R6050 before 1.0.1.10, R6220 before 1.1.0.50, R6700v2 before 1.2.0.4, R6800 before 1.2.0.4, R6900v2 before 1.2.0.4, WNDR3700v5 before 1.1.0.48, WNR1000v4 before 1.1.0.44, WNR2020 before 1.1.0.44, and WNR2050 before 1.1.0.44.
Affected products
- NETGEAR Jnr1010 Firmware: before 1.1.0.44 — fixed in 1.1.0.44
- NETGEAR JR6150: before 1.0.1.10 — fixed in 1.0.1.10
- NETGEAR Jwnr2010 Firmware: before 1.1.0.44 — fixed in 1.1.0.44
- NETGEAR Pr2000 Firmware: before 1.0.0.18 — fixed in 1.0.0.18
- NETGEAR R6050 Firmware: before 1.0.1.10 — fixed in 1.0.1.10
- NETGEAR R6220 Firmware: before 1.1.0.50 — fixed in 1.1.0.50
- NETGEAR R6700: before 1.2.0.4 — fixed in 1.2.0.4
- NETGEAR R6800 Firmware: before 1.2.0.4 — fixed in 1.2.0.4
- NETGEAR R6900 Firmware: before 1.2.0.4 — fixed in 1.2.0.4
- NETGEAR Wndr3700 Firmware: before 1.1.0.48 — fixed in 1.1.0.48
- NETGEAR Wnr1000 Firmware: before 1.1.0.44 — fixed in 1.1.0.44
- NETGEAR Wnr2020 Firmware: before 1.1.0.44 — fixed in 1.1.0.44
- NETGEAR Wnr2050 Firmware: before 1.1.0.44 — fixed in 1.1.0.44
How to fix
Upgrade to a fixed version: NETGEAR Jnr1010 Firmware 1.1.0.44; NETGEAR JR6150 1.0.1.10; NETGEAR Jwnr2010 Firmware 1.1.0.44; NETGEAR Pr2000 Firmware 1.0.0.18; NETGEAR R6050 Firmware 1.0.1.10; NETGEAR R6220 Firmware 1.1.0.50; NETGEAR R6700 1.2.0.4; NETGEAR R6800 Firmware 1.2.0.4; NETGEAR R6900 Firmware 1.2.0.4; NETGEAR Wndr3700 Firmware 1.1.0.48; NETGEAR Wnr1000 Firmware 1.1.0.44; NETGEAR Wnr2020 Firmware 1.1.0.44. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000051521/Security-Advisory-for-Pre-Authentication-Command-Injection-on-Some-Routers-and-Extenders-PSV-2017-2154
- https://kb.netgear.com/000051521/Security-Advisory-for-Pre-Authentication-Command-Injection-on-Some-Routers-and-Extenders-PSV-2017-2154
Get alerted when CVE-2017-18734 or the next vulnerability affects your stack