What’s Vulnerable › Vulnerabilities
CVE-2017-18735
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-23 · updated 2026-06-17
- Weakness: CWE-74
Description
Certain NETGEAR devices are affected by command injection by an unauthenticated attacker. This affects JR6150 before 1.0.1.10, PR2000 before 1.0.0.18, R6050 before 1.0.1.10, R6700v2 before 1.2.0.4, R6800 before 1.2.0.4, and R6900v2 before 1.2.0.4.
Affected products
- NETGEAR JR6150: before 1.0.1.10 — fixed in 1.0.1.10
- NETGEAR Pr2000 Firmware: before 1.0.0.18 — fixed in 1.0.0.18
- NETGEAR R6050 Firmware: before 1.0.1.10 — fixed in 1.0.1.10
- NETGEAR R6700: before 1.2.0.4 — fixed in 1.2.0.4
- NETGEAR R6800 Firmware: before 1.2.0.4 — fixed in 1.2.0.4
- NETGEAR R6900 Firmware: before 1.2.0.4 — fixed in 1.2.0.4
How to fix
Upgrade to a fixed version: NETGEAR JR6150 1.0.1.10; NETGEAR Pr2000 Firmware 1.0.0.18; NETGEAR R6050 Firmware 1.0.1.10; NETGEAR R6700 1.2.0.4; NETGEAR R6800 Firmware 1.2.0.4; NETGEAR R6900 Firmware 1.2.0.4. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000051520/Security-Advisory-for-Pre-Authentication-Command-Injection-on-Some-Routers-and-Extenders-PSV-2017-2143
- https://kb.netgear.com/000051520/Security-Advisory-for-Pre-Authentication-Command-Injection-on-Some-Routers-and-Extenders-PSV-2017-2143
Get alerted when CVE-2017-18735 or the next vulnerability affects your stack