What’s Vulnerable › Vulnerabilities

CVE-2017-18738

Description

Certain NETGEAR devices are affected by a stack-based buffer overflow by an unauthenticated attacker. This affects EX6150v2 before 1.0.1.54, R6400 before 1.0.1.24, R6400v2 before 1.0.2.32, R6700 before 1.0.1.22, R6900 before 1.0.1.22, R7000 before 1.0.9.10, R7000P before 1.2.0.22, R6900P before 1.2.0.22, R7100LG before 1.0.0.32, R7300DST before 1.0.0.54, R7900 before 1.0.1.18, R8000 before 1.0.3.48, R8300 before 1.0.2.106, R8500 before 1.0.2.106, R6100 before 1.0.1.16, WNDR4300v2 before 1.0.0.48, WNDR4500v3 before 1.0.0.48, and WNR2000v5 before 1.0.0.58.

Affected products

How to fix

Upgrade to a fixed version: Netgear EX6150 1.0.1.54; NETGEAR R6100 Firmware 1.0.1.16; NETGEAR R6400 Firmware 1.0.1.24, 1.0.2.32; NETGEAR R6700 1.0.1.22; NETGEAR R6900 Firmware 1.0.1.22; NETGEAR R6900P Firmware 1.2.0.22; NETGEAR R7000 1.0.9.10; NETGEAR R7000P 1.2.0.22; NETGEAR R7100Lg Firmware 1.0.0.32; NETGEAR R7300Dst Firmware 1.0.0.54; NETGEAR R7900 Firmware 1.0.1.18; NETGEAR R8000 Firmware 1.0.3.48. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-18738 or the next vulnerability affects your stack