What’s Vulnerable › Vulnerabilities
CVE-2017-18739
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-23 · updated 2026-06-17
- Weakness: CWE-120
Description
Certain NETGEAR devices are affected by a buffer overflow by an unauthenticated attacker. This affects R6220 before V1.1.0.50, R7800 before V1.0.2.36, WNDR3400v3 before 1.0.1.14, and WNDR3700v5 before V1.1.0.48.
Affected products
- NETGEAR R6220 Firmware: before 1.1.0.50 — fixed in 1.1.0.50
- NETGEAR R7800 Firmware: before 1.0.2.36 — fixed in 1.0.2.36
- NETGEAR Wndr3400 Firmware: before 1.0.1.14 — fixed in 1.0.1.14
- NETGEAR Wndr3700 Firmware: before 1.1.0.48 — fixed in 1.1.0.48
How to fix
Upgrade to a fixed version: NETGEAR R6220 Firmware 1.1.0.50; NETGEAR R7800 Firmware 1.0.2.36; NETGEAR Wndr3400 Firmware 1.0.1.14; NETGEAR Wndr3700 Firmware 1.1.0.48. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000051516/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-Some-Routers-PSV-2017-0670
- https://kb.netgear.com/000051516/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-Some-Routers-PSV-2017-0670
Get alerted when CVE-2017-18739 or the next vulnerability affects your stack