What’s Vulnerable › Vulnerabilities
CVE-2017-18744
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-23 · updated 2026-06-17
- Weakness: CWE-120
Description
Certain NETGEAR devices are affected by a buffer overflow by an unauthenticated attacker. This affects R6250 before 1.0.4.12, R6300v2 before 1.0.4.12, R6700 before 1.0.1.22, R6900 before 1.0.1.22, R7000 before 1.0.9.4, R7900 before 1.0.1.12, R8000 before 1.0.3.24, and R8500 before 1.0.2.74.
Affected products
- NETGEAR R6250 Firmware: before 1.0.4.12 — fixed in 1.0.4.12
- NETGEAR R6300 Firmware: before 1.0.4.12 — fixed in 1.0.4.12
- NETGEAR R6700: before 1.0.1.22 — fixed in 1.0.1.22
- NETGEAR R6900 Firmware: before 1.0.1.22 — fixed in 1.0.1.22
- NETGEAR R7000: before 1.0.9.4 — fixed in 1.0.9.4
- NETGEAR R7900 Firmware: before 1.0.1.12 — fixed in 1.0.1.12
- NETGEAR R8000 Firmware: before 1.0.3.24 — fixed in 1.0.3.24
- NETGEAR R8500 Firmware: before 1.0.2.74 — fixed in 1.0.2.74
How to fix
Upgrade to a fixed version: NETGEAR R6250 Firmware 1.0.4.12; NETGEAR R6300 Firmware 1.0.4.12; NETGEAR R6700 1.0.1.22; NETGEAR R6900 Firmware 1.0.1.22; NETGEAR R7000 1.0.9.4; NETGEAR R7900 Firmware 1.0.1.12; NETGEAR R8000 Firmware 1.0.3.24; NETGEAR R8500 Firmware 1.0.2.74. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000051511/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-Some-Routers-PSV-2017-0324
- https://kb.netgear.com/000051511/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-Some-Routers-PSV-2017-0324
Get alerted when CVE-2017-18744 or the next vulnerability affects your stack