What’s Vulnerable › Vulnerabilities
CVE-2017-18751
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-23 · updated 2026-06-17
- Weakness: CWE-787
Description
Certain NETGEAR devices are affected by a stack-based buffer overflow by an unauthenticated attacker. This affects D7800 before 1.0.1.28, R6100 before 1.0.1.16, R7500 before 1.0.0.112, R7500v2 before 1.0.3.20, R7800 before 1.0.2.36, R9000 before 1.0.2.52, WNDR3700v4 before 1.0.2.88, WNDR4300 before 1.0.2.90, WNDR4300v2 before 1.0.0.48, and WNDR4500v3 before 1.0.0.48.
Affected products
- NETGEAR D7800 Firmware: before 1.0.1.28 — fixed in 1.0.1.28
- NETGEAR R6100 Firmware: before 1.0.1.16 — fixed in 1.0.1.16
- NETGEAR R7500 Firmware: before 1.0.0.112; before 1.0.3.20 — fixed in 1.0.0.112, 1.0.3.20
- NETGEAR R7800 Firmware: before 1.0.2.36 — fixed in 1.0.2.36
- NETGEAR R9000 Firmware: before 1.0.2.52 — fixed in 1.0.2.52
- NETGEAR Wndr3700 Firmware: before 1.0.2.88 — fixed in 1.0.2.88
- NETGEAR Wndr4300 Firmware: before 1.0.2.90; before 1.0.0.48 — fixed in 1.0.0.48, 1.0.2.90
- Netgear WNDR4500: before 1.0.0.48 — fixed in 1.0.0.48
How to fix
Upgrade to a fixed version: NETGEAR D7800 Firmware 1.0.1.28; NETGEAR R6100 Firmware 1.0.1.16; NETGEAR R7500 Firmware 1.0.0.112, 1.0.3.20; NETGEAR R7800 Firmware 1.0.2.36; NETGEAR R9000 Firmware 1.0.2.52; NETGEAR Wndr3700 Firmware 1.0.2.88; NETGEAR Wndr4300 Firmware 1.0.0.48, 1.0.2.90; Netgear WNDR4500 1.0.0.48. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000051503/Security-Advisory-for-Pre-Authentication-Stack-Overflow-on-Some-Routers-and-Gateways-PSV-2017-2517
- https://kb.netgear.com/000051503/Security-Advisory-for-Pre-Authentication-Stack-Overflow-on-Some-Routers-and-Gateways-PSV-2017-2517
Get alerted when CVE-2017-18751 or the next vulnerability affects your stack