What’s Vulnerable › Vulnerabilities
CVE-2017-18769
- Severity: medium (CVSS 4.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-22 · updated 2026-06-17
- Weakness: CWE-200
Description
Certain NETGEAR devices are affected by an attacker's ability to read arbitrary files. This affects D6220 before 1.0.0.40, D6400 before 1.0.0.74, D7000 before 1.0.1.60, D7800 before 1.0.1.34, D8500 before 1.0.3.39, DGN2200v4 before 1.0.0.94, DGN2200Bv4 before 1.0.0.94, EX6200v2 before 1.0.1.50, EX7000 before 1.0.0.56, JR6150 before 1.0.1.18, R6050 before 1.0.1.10J, R6100 before 1.0.1.16, R6150 before 1.0.1.10, R6220 before 1.1.0.50, R6250 before 1.0.4.12, R6300v2 before 1.0.4.12, R6400 before 1.0.1.24, R6400v2 before 1.0.2.32, R6700 before 1.0.1.26, R6700v2 before 1.2.0.4, R6800 before 1.0.1.10, R6900 before 1.0.1.26, R6900P before 1.0.0.58, R6900v2 before 1.2.0.4, R7000 before 1.0.9.6, R7000P before 1.0.0.58, R7100LG before 1.0.0.32, R7300 before 1.0.0.54, R7500 before 1.0.0.112, R7500v2 before 1.0.3.20, R7800 before 1.0.2.36, R7900 before 1.0.1.18, R8000 before 1.0.3.48, R8300 before 1.0.2.104, R8500 before 1.0.2.104, R9000 before 1.0.2.40, WNDR3400v3 before 1.0.1.14, WNDR3700v4 before 1.0.2.96, WNDR4300v1 before 1.0.2.98, WNDR4300v2 before 1.0.0.48, WNDR4500v3 before 1.0.0.48, and WNR3500Lv2 before 1.2.0.44.
Affected products
- NETGEAR D6220 Firmware: before 1.0.0.40 — fixed in 1.0.0.40
- Netgear D6400: before 1.0.0.74 — fixed in 1.0.0.74
- NETGEAR D7000 Firmware: before 1.0.1.60 — fixed in 1.0.1.60
- NETGEAR D7800 Firmware: before 1.0.1.34 — fixed in 1.0.1.34
- NETGEAR D8500 Firmware: before 1.0.3.39 — fixed in 1.0.3.39
- NETGEAR Dgn2200 Firmware: before 1.0.0.94 — fixed in 1.0.0.94
- Netgear DGN2200B: before 1.0.0.94 — fixed in 1.0.0.94
- Netgear EX6200: before 1.0.1.50 — fixed in 1.0.1.50
- NETGEAR Ex7000 Firmware: before 1.0.0.56 — fixed in 1.0.0.56
- NETGEAR JR6150: before 1.0.1.18 — fixed in 1.0.1.18
- NETGEAR R6050 Firmware: before 1.0.1.10j — fixed in 1.0.1.10j
- NETGEAR R6100 Firmware: before 1.0.1.16 — fixed in 1.0.1.16
- NETGEAR R6150 Firmware: before 1.0.1.10 — fixed in 1.0.1.10
- NETGEAR R6220 Firmware: before 1.1.0.50 — fixed in 1.1.0.50
- NETGEAR R6250 Firmware: before 1.0.4.12 — fixed in 1.0.4.12
- NETGEAR R6300 Firmware: before 1.0.4.12 — fixed in 1.0.4.12
- NETGEAR R6400 Firmware: before 1.0.1.24; before 1.0.2.32 — fixed in 1.0.1.24, 1.0.2.32
- NETGEAR R6700: before 1.0.1.26; before 1.2.0.4 — fixed in 1.0.1.26, 1.2.0.4
- NETGEAR R6800 Firmware: before 1.0.1.10 — fixed in 1.0.1.10
- NETGEAR R6900 Firmware: before 1.0.1.26; before 1.2.0.4 — fixed in 1.0.1.26, 1.2.0.4
- NETGEAR R6900P Firmware: before 1.0.0.58 — fixed in 1.0.0.58
- NETGEAR R7000: before 1.0.9.6 — fixed in 1.0.9.6
- NETGEAR R7000P: before 1.0.0.58 — fixed in 1.0.0.58
- NETGEAR R7100Lg Firmware: before 1.0.0.32 — fixed in 1.0.0.32
- NETGEAR R7300 Firmware: before 1.0.0.54 — fixed in 1.0.0.54
- NETGEAR R7500 Firmware: before 1.0.0.112; before 1.0.3.20 — fixed in 1.0.0.112, 1.0.3.20
- NETGEAR R7800 Firmware: before 1.0.2.36 — fixed in 1.0.2.36
- NETGEAR R7900 Firmware: before 1.0.1.18 — fixed in 1.0.1.18
- NETGEAR R8000 Firmware: before 1.0.3.48 — fixed in 1.0.3.48
- NETGEAR R8300 Firmware: before 1.0.2.104 — fixed in 1.0.2.104
How to fix
Upgrade to a fixed version: NETGEAR D6220 Firmware 1.0.0.40; Netgear D6400 1.0.0.74; NETGEAR D7000 Firmware 1.0.1.60; NETGEAR D7800 Firmware 1.0.1.34; NETGEAR D8500 Firmware 1.0.3.39; NETGEAR Dgn2200 Firmware 1.0.0.94; Netgear DGN2200B 1.0.0.94; Netgear EX6200 1.0.1.50; NETGEAR Ex7000 Firmware 1.0.0.56; NETGEAR JR6150 1.0.1.18; NETGEAR R6050 Firmware 1.0.1.10j; NETGEAR R6100 Firmware 1.0.1.16. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000051474/Security-Advisory-for-Arbitrary-File-Read-on-Some-Routers-Gateways-and-Extenders-PSV-2016-0122
- https://kb.netgear.com/000051474/Security-Advisory-for-Arbitrary-File-Read-on-Some-Routers-Gateways-and-Extenders-PSV-2016-0122
Get alerted when CVE-2017-18769 or the next vulnerability affects your stack