What’s Vulnerable › Vulnerabilities
CVE-2017-18770
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-22 · updated 2026-06-17
- Weakness: CWE-120
Description
Certain NETGEAR devices are affected by a buffer overflow by an authenticated user. This affects R7800 before 1.0.2.36, PLW1000v2 before 1.0.0.14, and PLW1010v2 before 1.0.0.14.
Affected products
- NETGEAR Plw1000 Firmware: before 1.0.0.14 — fixed in 1.0.0.14
- NETGEAR Plw1010 Firmware: before 1.0.0.14 — fixed in 1.0.0.14
- NETGEAR R7800 Firmware: before 1.0.2.36 — fixed in 1.0.2.36
How to fix
Upgrade to a fixed version: NETGEAR Plw1000 Firmware 1.0.0.14; NETGEAR Plw1010 Firmware 1.0.0.14; NETGEAR R7800 Firmware 1.0.2.36. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000051473/Security-Advisory-for-Post-Authentication-Buffer-Overflow-on-Powerlines-and-a-Router-PSV-2016-0121
- https://kb.netgear.com/000051473/Security-Advisory-for-Post-Authentication-Buffer-Overflow-on-Powerlines-and-a-Router-PSV-2016-0121
Get alerted when CVE-2017-18770 or the next vulnerability affects your stack