What’s Vulnerable › Vulnerabilities

CVE-2017-18784

Description

Certain NETGEAR devices are affected by XSS. This affects D6200 before 1.1.00.24, D7000 before 1.0.1.52, JNR1010v2 before 1.1.0.44, JWNR2010v5 before 1.1.0.44, PR2000 before 1.0.0.20, R6020 before 1.0.0.26, R6050 before 1.0.1.12, R6080 before 1.0.0.26, R6120 before 1.0.0.36, R6220 before 1.1.0.60, R6700v2 before 1.2.0.12, R6800 before 1.2.0.12, R6900v2 before 1.2.0.12, WNDR3700v5 before 1.1.0.50, WNR1000v4 before 1.1.0.44, WNR2020 before 1.1.0.44, and WNR2050 before 1.1.0.44.

Affected products

How to fix

Upgrade to a fixed version: NETGEAR D6200 Firmware 1.1.00.24; NETGEAR D7000 Firmware 1.0.1.52; NETGEAR Jnr1010 Firmware 1.1.0.44; NETGEAR Jwnr2010 Firmware 1.1.0.44; NETGEAR Pr2000 Firmware 1.0.0.20; NETGEAR R6020 Firmware 1.0.0.26; NETGEAR R6050 Firmware 1.0.1.12; NETGEAR R6080 Firmware 1.0.0.26; NETGEAR R6120 Firmware 1.0.0.36; NETGEAR R6220 Firmware 1.1.0.60; NETGEAR R6700 1.2.0.12; NETGEAR R6800 Firmware 1.2.0.12. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-18784 or the next vulnerability affects your stack