What’s Vulnerable › Vulnerabilities
CVE-2017-18787
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-22 · updated 2026-06-17
- Weakness: CWE-74
Description
Certain NETGEAR devices are affected by command injection. This affects D6200 before 1.1.00.24, JNR1010v2 before 1.1.0.44, JR6150 before 1.0.1.12, JWNR2010v5 before 1.1.0.44, PR2000 before 1.0.0.20, R6050, before 1.0.1.12, WNR1000v4 before 1.1.0.44, WNR2020 before 1.1.0.44, and WNR2050 before 1.1.0.44.
Affected products
- NETGEAR D6200 Firmware: before 1.1.00.24 — fixed in 1.1.00.24
- NETGEAR Jnr1010 Firmware: before 1.1.0.44 — fixed in 1.1.0.44
- NETGEAR JR6150: before 1.0.1.12 — fixed in 1.0.1.12
- NETGEAR Jwnr2010 Firmware: before 1.1.0.44 — fixed in 1.1.0.44
- NETGEAR Pr2000 Firmware: before 1.0.0.20 — fixed in 1.0.0.20
- NETGEAR R6050 Firmware: before 1.0.1.12 — fixed in 1.0.1.12
- NETGEAR Wnr1000 Firmware: before 1.1.0.44 — fixed in 1.1.0.44
- NETGEAR Wnr2020 Firmware: before 1.1.0.44 — fixed in 1.1.0.44
- NETGEAR Wnr2050 Firmware: before 1.1.0.44 — fixed in 1.1.0.44
How to fix
Upgrade to a fixed version: NETGEAR D6200 Firmware 1.1.00.24; NETGEAR Jnr1010 Firmware 1.1.0.44; NETGEAR JR6150 1.0.1.12; NETGEAR Jwnr2010 Firmware 1.1.0.44; NETGEAR Pr2000 Firmware 1.0.0.20; NETGEAR R6050 Firmware 1.0.1.12; NETGEAR Wnr1000 Firmware 1.1.0.44; NETGEAR Wnr2020 Firmware 1.1.0.44; NETGEAR Wnr2050 Firmware 1.1.0.44. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000049528/Security-Advisory-for-Command-Injection-on-Some-Routers-PSV-2017-2948
- https://kb.netgear.com/000049528/Security-Advisory-for-Command-Injection-on-Some-Routers-PSV-2017-2948
Get alerted when CVE-2017-18787 or the next vulnerability affects your stack