What’s Vulnerable › Vulnerabilities
CVE-2017-18791
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-21 · updated 2026-06-17
- Weakness: CWE-352
Description
Certain NETGEAR devices are affected by CSRF. This affects R6050/JR6150 before 1.0.1.7, PR2000 before 1.0.0.17, R6220 before 1.1.0.50, WNDR3700v5 before 1.1.0.48, JNR1010v2 before 1.1.0.40, JWNR2010v5 before 1.1.0.40, WNR1000v4 before 1.1.0.40, WNR2020 before 1.1.0.40, WNR2050 before 1.1.0.40, WNR614 before 1.1.0.40, WNR618 before 1.1.0.40, and D7000 before 1.0.1.50.
Affected products
- NETGEAR D7000 Firmware: before 1.0.1.50 — fixed in 1.0.1.50
- NETGEAR Jnr1010 Firmware: before 1.1.0.40 — fixed in 1.1.0.40
- NETGEAR JR6150: before 1.0.1.7 — fixed in 1.0.1.7
- NETGEAR Jwnr2010 Firmware: before 1.1.0.40 — fixed in 1.1.0.40
- NETGEAR Pr2000 Firmware: before 1.0.0.17 — fixed in 1.0.0.17
- NETGEAR R6050 Firmware: before 1.0.1.7 — fixed in 1.0.1.7
- NETGEAR R6220 Firmware: before 1.1.0.50 — fixed in 1.1.0.50
- NETGEAR Wndr3700 Firmware: before 1.1.0.48 — fixed in 1.1.0.48
- NETGEAR Wnr1000 Firmware: before 1.1.0.40 — fixed in 1.1.0.40
- NETGEAR Wnr2020 Firmware: before 1.1.0.40 — fixed in 1.1.0.40
- NETGEAR Wnr2050 Firmware: before 1.1.0.40 — fixed in 1.1.0.40
- Netgear WNR614: before 1.1.0.40 — fixed in 1.1.0.40
- NETGEAR Wnr618 Firmware: before 1.1.0.40 — fixed in 1.1.0.40
How to fix
Upgrade to a fixed version: NETGEAR D7000 Firmware 1.0.1.50; NETGEAR Jnr1010 Firmware 1.1.0.40; NETGEAR JR6150 1.0.1.7; NETGEAR Jwnr2010 Firmware 1.1.0.40; NETGEAR Pr2000 Firmware 1.0.0.17; NETGEAR R6050 Firmware 1.0.1.7; NETGEAR R6220 Firmware 1.1.0.50; NETGEAR Wndr3700 Firmware 1.1.0.48; NETGEAR Wnr1000 Firmware 1.1.0.40; NETGEAR Wnr2020 Firmware 1.1.0.40; NETGEAR Wnr2050 Firmware 1.1.0.40; Netgear WNR614 1.1.0.40. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000049371/Security-Advisory-for-Cross-Site-Request-Forgery-Vulnerability-on-D7000-and-Some-Routers-PSV-2017-0386
- https://kb.netgear.com/000049371/Security-Advisory-for-Cross-Site-Request-Forgery-Vulnerability-on-D7000-and-Some-Routers-PSV-2017-0386
Get alerted when CVE-2017-18791 or the next vulnerability affects your stack