What’s Vulnerable › Vulnerabilities
CVE-2017-18795
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-21 · updated 2026-06-17
- Weakness: CWE-74
Description
Certain NETGEAR devices are affected by command injection. This affects D6220 before 1.0.0.28 and D6100 before 1.0.0.50_0.0.50.
Affected products
- NETGEAR D6100 Firmware: before 1.0.0.50_0.0.50 — fixed in 1.0.0.50_0.0.50
- NETGEAR D6220 Firmware: before 1.0.0.28 — fixed in 1.0.0.28
How to fix
Upgrade to a fixed version: NETGEAR D6100 Firmware 1.0.0.50_0.0.50; NETGEAR D6220 Firmware 1.0.0.28. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000049367/Security-Advisory-for-Command-Injection-Vulnerability-on-D6220-and-D6100-PSV-2016-0133
- https://kb.netgear.com/000049367/Security-Advisory-for-Command-Injection-Vulnerability-on-D6220-and-D6100-PSV-2016-0133
Get alerted when CVE-2017-18795 or the next vulnerability affects your stack