What’s Vulnerable › Vulnerabilities
CVE-2017-18796
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-21 · updated 2026-06-17
- Weakness: CWE-74
Description
Certain NETGEAR devices are affected by command injection. This affects R6400 before 1.0.1.24, R6700 before 1.0.1.26, R6900 before 1.0.1.28, R7000 before 1.0.9.10, R7000P before 1.0.1.16, R6900P before 1.0.1.16, and R7800 before 1.0.2.36.
Affected products
- NETGEAR R6400 Firmware: before 1.0.1.24 — fixed in 1.0.1.24
- NETGEAR R6700: before 1.0.1.26 — fixed in 1.0.1.26
- NETGEAR R6900 Firmware: before 1.0.1.28 — fixed in 1.0.1.28
- NETGEAR R6900P Firmware: before 1.0.1.16 — fixed in 1.0.1.16
- NETGEAR R7000: before 1.0.9.10 — fixed in 1.0.9.10
- NETGEAR R7000P: before 1.0.1.16 — fixed in 1.0.1.16
- NETGEAR R7800 Firmware: before 1.0.2.36 — fixed in 1.0.2.36
How to fix
Upgrade to a fixed version: NETGEAR R6400 Firmware 1.0.1.24; NETGEAR R6700 1.0.1.26; NETGEAR R6900 Firmware 1.0.1.28; NETGEAR R6900P Firmware 1.0.1.16; NETGEAR R7000 1.0.9.10; NETGEAR R7000P 1.0.1.16; NETGEAR R7800 Firmware 1.0.2.36. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000049366/Security-Advisory-for-Command-Injection-Vulnerability-on-Some-Routers-PSV-2016-0106
- https://kb.netgear.com/000049366/Security-Advisory-for-Command-Injection-Vulnerability-on-Some-Routers-PSV-2016-0106
Get alerted when CVE-2017-18796 or the next vulnerability affects your stack