What’s Vulnerable › Vulnerabilities
CVE-2017-18801
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-21 · updated 2026-06-17
- Weakness: CWE-74
Description
Certain NETGEAR devices are affected by command injection. This affects R6220 before 1.1.0.50, R6700v2 before 1.1.0.38, R6800 before 1.1.0.38, WNDR3700v5 before 1.1.0.48, and D7000 before 1.0.1.50.
Affected products
- NETGEAR D7000 Firmware: before 1.0.1.50 — fixed in 1.0.1.50
- NETGEAR R6220 Firmware: before 1.1.0.50 — fixed in 1.1.0.50
- NETGEAR R6700: before 1.1.0.38 — fixed in 1.1.0.38
- NETGEAR R6800 Firmware: before 1.1.0.38 — fixed in 1.1.0.38
- NETGEAR Wndr3700 Firmware: before 1.1.0.48 — fixed in 1.1.0.48
How to fix
Upgrade to a fixed version: NETGEAR D7000 Firmware 1.0.1.50; NETGEAR R6220 Firmware 1.1.0.50; NETGEAR R6700 1.1.0.38; NETGEAR R6800 Firmware 1.1.0.38; NETGEAR Wndr3700 Firmware 1.1.0.48. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000049355/Security-Advisory-for-Command-Injection-Vulnerability-on-D7000-and-Some-Routers-PSV-2017-2151
- https://kb.netgear.com/000049355/Security-Advisory-for-Command-Injection-Vulnerability-on-D7000-and-Some-Routers-PSV-2017-2151
Get alerted when CVE-2017-18801 or the next vulnerability affects your stack