What’s Vulnerable › Vulnerabilities
CVE-2017-18834
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Certain NETGEAR devices are affected by reflected XSS. This affects M4300-28G before 12.0.2.15, M4300-52G before 12.0.2.15, M4300-28G-POE+ before 12.0.2.15, M4300-52G-POE+ before 12.0.2.15, M4300-8X8F before 12.0.2.15, M4300-12X12F before 12.0.2.15, M4300-24X24F before 12.0.2.15, M4300-24X before 12.0.2.15, M4300-48X before 12.0.2.15, and M4200 before 12.0.2.15.
Affected products
- NETGEAR M4200 Firmware: before 12.0.2.15 — fixed in 12.0.2.15
- NETGEAR M4300-12X12F Firmware: before 12.0.2.15 — fixed in 12.0.2.15
- NETGEAR M4300-24X24F Firmware: before 12.0.2.15 — fixed in 12.0.2.15
- NETGEAR M4300-24X Firmware: before 12.0.2.15 — fixed in 12.0.2.15
- NETGEAR M4300-28G-Poe+ Firmware: before 12.0.2.15 — fixed in 12.0.2.15
- NETGEAR M4300-28G Firmware: before 12.0.2.15 — fixed in 12.0.2.15
- NETGEAR M4300-48X Firmware: before 12.0.2.15 — fixed in 12.0.2.15
- NETGEAR M4300-52G-Poe+ Firmware: before 12.0.2.15 — fixed in 12.0.2.15
- NETGEAR M4300-52G Firmware: before 12.0.2.15 — fixed in 12.0.2.15
- NETGEAR M4300-8X8F Firmware: before 12.0.2.15 — fixed in 12.0.2.15
How to fix
Upgrade to a fixed version: NETGEAR M4200 Firmware 12.0.2.15; NETGEAR M4300-12X12F Firmware 12.0.2.15; NETGEAR M4300-24X24F Firmware 12.0.2.15; NETGEAR M4300-24X Firmware 12.0.2.15; NETGEAR M4300-28G-Poe+ Firmware 12.0.2.15; NETGEAR M4300-28G Firmware 12.0.2.15; NETGEAR M4300-48X Firmware 12.0.2.15; NETGEAR M4300-52G-Poe+ Firmware 12.0.2.15; NETGEAR M4300-52G Firmware 12.0.2.15; NETGEAR M4300-8X8F Firmware 12.0.2.15. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000049028/Security-Advisory-for-Reflected-Cross-Site-Scripting-on-Some-Fully-Managed-Switches-PSV-2017-1956
- https://kb.netgear.com/000049028/Security-Advisory-for-Reflected-Cross-Site-Scripting-on-Some-Fully-Managed-Switches-PSV-2017-1956
Get alerted when CVE-2017-18834 or the next vulnerability affects your stack