What’s Vulnerable › Vulnerabilities
CVE-2017-18841
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-20 · updated 2026-06-17
- Weakness: CWE-74
Description
Certain NETGEAR devices are affected by command injection. This affects R6220 before 1.1.0.46, R6700v2 before 1.1.0.38, R6800 before 1.1.0.38, WNDR3700v5 before 1.1.0.46, and D7000 before 1.0.1.50.
Affected products
- NETGEAR D7000 Firmware: before 1.0.1.50 — fixed in 1.0.1.50
- NETGEAR R6220 Firmware: before 1.1.0.46 — fixed in 1.1.0.46
- NETGEAR R6700: before 1.1.0.38 — fixed in 1.1.0.38
- NETGEAR R6800 Firmware: before 1.1.0.38 — fixed in 1.1.0.38
- NETGEAR Wndr3700 Firmware: before 1.1.0.46 — fixed in 1.1.0.46
How to fix
Upgrade to a fixed version: NETGEAR D7000 Firmware 1.0.1.50; NETGEAR R6220 Firmware 1.1.0.46; NETGEAR R6700 1.1.0.38; NETGEAR R6800 Firmware 1.1.0.38; NETGEAR Wndr3700 Firmware 1.1.0.46. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000049018/Security-Advisory-for-Command-Injection-on-Some-Routers-and-a-Modem-Router-PSV-2017-2158
- https://kb.netgear.com/000049018/Security-Advisory-for-Command-Injection-on-Some-Routers-and-a-Modem-Router-PSV-2017-2158
Get alerted when CVE-2017-18841 or the next vulnerability affects your stack