What’s Vulnerable › Vulnerabilities
CVE-2017-18851
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-20 · updated 2026-06-17
- Weakness: CWE-74
Description
Certain NETGEAR devices are affected by command injection by an authenticated user. This affects D8500 through 1.0.3.28, R6400 through 1.0.1.22, R6400v2 through 1.0.2.18, R8300 through 1.0.2.94, R8500 through 1.0.2.94, and R6100 through 1.0.1.12.
Affected products
- NETGEAR D8500 Firmware: before 1.0.3.28 — fixed in 1.0.3.28
- NETGEAR R6100 Firmware: before 1.0.1.12 — fixed in 1.0.1.12
- NETGEAR R6400 Firmware: before 1.0.1.22; before 1.0.2.18 — fixed in 1.0.1.22, 1.0.2.18
- NETGEAR R8300 Firmware: before 1.0.2.94 — fixed in 1.0.2.94
- NETGEAR R8500 Firmware: before 1.0.2.94 — fixed in 1.0.2.94
How to fix
Upgrade to a fixed version: NETGEAR D8500 Firmware 1.0.3.28; NETGEAR R6100 Firmware 1.0.1.12; NETGEAR R6400 Firmware 1.0.1.22, 1.0.2.18; NETGEAR R8300 Firmware 1.0.2.94; NETGEAR R8500 Firmware 1.0.2.94. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000045850/Security-Advisory-for-Post-Authentication-Command-Injection-on-Some-Routers-and-Modem-Routers-PSV-2017-1207
- https://kb.netgear.com/000045850/Security-Advisory-for-Post-Authentication-Command-Injection-on-Some-Routers-and-Modem-Routers-PSV-2017-1207
Get alerted when CVE-2017-18851 or the next vulnerability affects your stack