What’s Vulnerable › Vulnerabilities
CVE-2017-18864
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-05-05 · updated 2026-06-17
- Weakness: CWE-120
Description
Certain NETGEAR devices are affected by a buffer overflow by an unauthenticated attacker. This affects R6400 before 1.0.1.24, R6400v2 before 1.0.2.32, R6700 before 1.0.1.22, R6900 before 1.0.1.22, R7000 before 1.0.9.4, R7000P before 1.0.0.56, R6900P before 1.0.0.56, R7100LG before 1.0.0.32, R7300 before 1.0.0.54, R7900 before 1.0.1.18, R8300 before 1.0.2.104, and R8500 before 1.0.2.104.
Affected products
- NETGEAR R6400 Firmware: before 1.0.1.24; before 1.0.2.32 — fixed in 1.0.1.24, 1.0.2.32
- NETGEAR R6700: before 1.0.1.22 — fixed in 1.0.1.22
- NETGEAR R6900 Firmware: before 1.0.1.22 — fixed in 1.0.1.22
- NETGEAR R6900P Firmware: before 1.0.0.56 — fixed in 1.0.0.56
- NETGEAR R7000: before 1.0.9.4 — fixed in 1.0.9.4
- NETGEAR R7000P: before 1.0.0.56 — fixed in 1.0.0.56
- NETGEAR R7100Lg Firmware: before 1.0.0.32 — fixed in 1.0.0.32
- NETGEAR R7300 Firmware: before 1.0.0.54 — fixed in 1.0.0.54
- NETGEAR R7900 Firmware: before 1.0.1.18 — fixed in 1.0.1.18
- NETGEAR R8300 Firmware: before 1.0.2.104 — fixed in 1.0.2.104
- NETGEAR R8500 Firmware: before 1.0.2.104 — fixed in 1.0.2.104
How to fix
Upgrade to a fixed version: NETGEAR R6400 Firmware 1.0.1.24, 1.0.2.32; NETGEAR R6700 1.0.1.22; NETGEAR R6900 Firmware 1.0.1.22; NETGEAR R6900P Firmware 1.0.0.56; NETGEAR R7000 1.0.9.4; NETGEAR R7000P 1.0.0.56; NETGEAR R7100Lg Firmware 1.0.0.32; NETGEAR R7300 Firmware 1.0.0.54; NETGEAR R7900 Firmware 1.0.1.18; NETGEAR R8300 Firmware 1.0.2.104; NETGEAR R8500 Firmware 1.0.2.104. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000051495/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-Routers-PSV-2017-0791
- https://kb.netgear.com/000051495/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-Routers-PSV-2017-0791
Get alerted when CVE-2017-18864 or the next vulnerability affects your stack