What’s Vulnerable › Vulnerabilities
CVE-2017-18865
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-05-05 · updated 2026-06-17
- Weakness: CWE-787
Description
Certain NETGEAR devices are affected by a stack-based buffer overflow by an authenticated user. This affects R8300 before 1.0.2.104 and R8500 before 1.0.2.104.
Affected products
- NETGEAR R8300 Firmware: before 1.0.2.104 — fixed in 1.0.2.104
- NETGEAR R8500 Firmware: before 1.0.2.104 — fixed in 1.0.2.104
How to fix
Upgrade to a fixed version: NETGEAR R8300 Firmware 1.0.2.104; NETGEAR R8500 Firmware 1.0.2.104. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000051485/Security-Advisory-for-Post-Authentication-Stack-Overflow-on-R8300-and-R8500-PSV-2017-2228
- https://kb.netgear.com/000051485/Security-Advisory-for-Post-Authentication-Stack-Overflow-on-R8300-and-R8500-PSV-2017-2228
Get alerted when CVE-2017-18865 or the next vulnerability affects your stack