What’s Vulnerable › Vulnerabilities
CVE-2017-18871
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-19 · updated 2026-06-17
Description
An issue was discovered in Mattermost Server before 4.5.0, 4.4.5, 4.3.4, and 4.2.2. It allows attackers to cause a denial of service (application crash) via an @ character before a JavaScript field name.
Affected products
- Mattermost: before 4.2.2; from 4.3.0 before 4.3.4; from 4.4.0 before 4.4.5; 4.5.0-rc1, 4.5.0-rc2, 4.5.0-rc3, 4.5.0-rc4 — fixed in 4.2.2, 4.3.4, 4.4.5
How to fix
Upgrade to a fixed version: Mattermost 4.2.2, 4.3.4, 4.4.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2017-18871 or the next vulnerability affects your stack