What’s Vulnerable › Vulnerabilities

CVE-2017-18894

Description

An issue was discovered in Mattermost Server before 4.2.0, 4.1.1, and 4.0.5, when used as an OAuth 2.0 service provider. Sometimes. resource-owner authorization is bypassed, allowing account takeover.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 4.0.5, 4.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-18894 or the next vulnerability affects your stack