What’s Vulnerable › Vulnerabilities
CVE-2017-18906
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-19 · updated 2026-06-17
- Weakness: CWE-287
Description
An issue was discovered in Mattermost Server before 4.0.0, 3.10.2, and 3.9.2, when Single Sign-On OAuth2 is used. An attacker could claim somebody else's account.
Affected products
- Mattermost: before 3.9.2; from 3.10.0 before 3.10.2 — fixed in 3.10.2, 3.9.2
How to fix
Upgrade to a fixed version: Mattermost 3.10.2, 3.9.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2017-18906 or the next vulnerability affects your stack