What’s Vulnerable › Vulnerabilities
CVE-2017-18917
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-19 · updated 2026-06-17
- Weakness: CWE-916
Description
An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. Weak hashing was used for e-mail invitations, OAuth, and e-mail verification tokens.
Affected products
- Mattermost: from 3.6.0 before 3.6.7; from 3.7.0 before 3.7.5; from 3.8.0 before 3.8.2 — fixed in 3.6.7, 3.7.5, 3.8.2
How to fix
Upgrade to a fixed version: Mattermost 3.6.7, 3.7.5, 3.8.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2017-18917 or the next vulnerability affects your stack