What’s Vulnerable › Vulnerabilities
CVE-2017-18918
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-19 · updated 2026-06-17
- Weakness: CWE-295
Description
An issue was discovered in Mattermost Server before 3.7.3 and 3.6.5. A System Administrator can place a SAML certificate at an arbitrary pathname.
Affected products
- Mattermost: from 3.6.0 before 3.6.5; from 3.7.0 before 3.7.3 — fixed in 3.6.5, 3.7.3
How to fix
Upgrade to a fixed version: Mattermost 3.6.5, 3.7.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2017-18918 or the next vulnerability affects your stack