What’s Vulnerable › Vulnerabilities
CVE-2017-20005
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-06 · updated 2026-06-17
- Weakness: CWE-190
Description
NGINX before 1.13.6 has a buffer overflow for years that exceed four digits, as demonstrated by a file with a modification date in 1969 that causes an integer overflow (or a false modification date far in the future), when encountered by the autoindex module.
Affected products
- Debian Linux: 9.0
- nginx: before 1.13.6 — fixed in 1.13.6
How to fix
Upgrade to a fixed version: nginx 1.13.6. Check the vendor advisory for mitigations.
References
- http://nginx.org/en/CHANGES
- https://github.com/nginx/nginx/commit/0206ebe76f748bb39d9de4dd4b3fce777fdfdccf
- https://github.com/nginx/nginx/commit/b900cc28fcbb4cf5a32ab62f80b59292e1c85b4b
- https://lists.debian.org/debian-lts-announce/2021/06/msg00009.html
- https://security.netapp.com/advisory/ntap-20210805-0006/
- https://trac.nginx.org/nginx/ticket/1368
- http://nginx.org/en/CHANGES
- https://github.com/nginx/nginx/commit/0206ebe76f748bb39d9de4dd4b3fce777fdfdccf
- https://github.com/nginx/nginx/commit/b900cc28fcbb4cf5a32ab62f80b59292e1c85b4b
- https://lists.debian.org/debian-lts-announce/2021/06/msg00009.html
- https://security.netapp.com/advisory/ntap-20210805-0006/
- https://trac.nginx.org/nginx/ticket/1368
Get alerted when CVE-2017-20005 or the next vulnerability affects your stack