What’s Vulnerable › Vulnerabilities
CVE-2017-20008: myCRED < 1.7.8 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The myCred WordPress plugin before 1.7.8 does not sanitise and escape the user parameter before outputting it back in the Points Log admin dashboard, leading to a Reflected Cross-Site Scripting
Affected products
- saadiqbal Points Management System For Gamification, Ranks, Badges, and Loyalty Rewards Program – myCred: before 1.7.8 — fixed in 1.7.8
How to fix
Upgrade to a fixed version: saadiqbal Points Management System For Gamification, Ranks, Badges, and Loyalty Rewards Program – myCred 1.7.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/1639363/mycred
- https://wpscan.com/vulnerability/3175c56d-27bb-4bf1-b6ba-737541483d40
- https://plugins.trac.wordpress.org/changeset/1639363/mycred
- https://wpscan.com/vulnerability/3175c56d-27bb-4bf1-b6ba-737541483d40
Get alerted when CVE-2017-20008 or the next vulnerability affects your stack