What’s Vulnerable › Vulnerabilities
CVE-2017-20017: The Next Generation of Genealogy Sitebuilding timeline2.php sql injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-08 · updated 2026-06-17
- Weakness: CWE-89
Description
A vulnerability, which was classified as critical, has been found in The Next Generation of Genealogy Sitebuilding up to 11.1.0. This issue affects some unknown processing of the file /timeline2.php. The manipulation of the argument primaryID leads to sql injection. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 11.1.1 is able to address this issue. It is recommended to upgrade the affected component.
Affected products
- The Next Generation of Genealogy Sitebuilding: through 11.1.0
References
Get alerted when CVE-2017-20017 or the next vulnerability affects your stack