What’s Vulnerable › Vulnerabilities
CVE-2017-20146: Improper access control in github.com/gorilla/handlers
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-27 · updated 2026-06-17
- Weakness: CWE-346
Description
Usage of the CORS handler may apply improper CORS headers, allowing the requester to explicitly control the value of the Access-Control-Allow-Origin header, which bypasses the expected behavior of the Same Origin Policy.
Affected products
- github.com/gorilla/handlers: before 1.3.0 — fixed in 1.3.0
How to fix
Upgrade to a fixed version: github.com/gorilla/handlers 1.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/gorilla/handlers/commit/90663712d74cb411cbef281bc1e08c19d1a76145
- https://github.com/gorilla/handlers/pull/116
- https://pkg.go.dev/vuln/GO-2020-0020
- https://github.com/gorilla/handlers/commit/90663712d74cb411cbef281bc1e08c19d1a76145
- https://github.com/gorilla/handlers/pull/116
- https://pkg.go.dev/vuln/GO-2020-0020
Get alerted when CVE-2017-20146 or the next vulnerability affects your stack