What’s Vulnerable › Vulnerabilities
CVE-2017-20154: ghostlander Phoenixcoin main.cpp accept denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-30 · updated 2026-06-17
- Weakness: CWE-404
Description
A vulnerability was found in ghostlander Phoenixcoin. It has been classified as problematic. Affected is the function CTxMemPool::accept of the file src/main.cpp. The manipulation leads to denial of service. Upgrading to version 0.6.6.1-pxc is able to address this issue. The name of the patch is 987dd68f71a7d8276cef3b6c3d578fd4845b5699. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217068.
Affected products
- ghostlander Phoenixcoin: before 0.6.6.1 — fixed in 0.6.6.1
How to fix
Upgrade to a fixed version: ghostlander Phoenixcoin 0.6.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/ghostlander/Phoenixcoin/commit/987dd68f71a7d8276cef3b6c3d578fd4845b5699
- https://github.com/ghostlander/Phoenixcoin/releases/tag/v0.6.6.1-pxc
- https://vuldb.com/?ctiid.217068
- https://vuldb.com/?id.217068
- https://github.com/ghostlander/Phoenixcoin/commit/987dd68f71a7d8276cef3b6c3d578fd4845b5699
- https://github.com/ghostlander/Phoenixcoin/releases/tag/v0.6.6.1-pxc
- https://vuldb.com/?ctiid.217068
- https://vuldb.com/?id.217068
Get alerted when CVE-2017-20154 or the next vulnerability affects your stack