What’s Vulnerable › Vulnerabilities
CVE-2017-20159: rf Keynote rumble.rb cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-31 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability was found in rf Keynote up to 0.x on Rails. It has been rated as problematic. Affected by this issue is some unknown functionality of the file lib/keynote/rumble.rb. The manipulation of the argument value leads to cross site scripting. The attack may be launched remotely. Upgrading to version 1.0.0 is able to address this issue. The patch is identified as 05be4356b0a6ca7de48da926a9b997beb5ffeb4a. It is recommended to upgrade the affected component. VDB-217142 is the identifier assigned to this vulnerability.
Affected products
- rf Keynote: before 1.0.0 — fixed in 1.0.0
How to fix
Upgrade to a fixed version: rf Keynote 1.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/rf-/keynote/commit/05be4356b0a6ca7de48da926a9b997beb5ffeb4a
- https://github.com/rf-/keynote/releases/tag/v1.0.0
- https://vuldb.com/?ctiid.217142
- https://vuldb.com/?id.217142
- https://github.com/rf-/keynote/commit/05be4356b0a6ca7de48da926a9b997beb5ffeb4a
- https://github.com/rf-/keynote/releases/tag/v1.0.0
- https://vuldb.com/?ctiid.217142
- https://vuldb.com/?id.217142
Get alerted when CVE-2017-20159 or the next vulnerability affects your stack