What’s Vulnerable › Vulnerabilities
CVE-2017-20160: flitto express-param fetchParams.js parameter pollution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-31 · updated 2026-06-17
- Weakness: CWE-235
Description
A vulnerability was found in flitto express-param up to 0.x. It has been classified as critical. This affects an unknown part of the file lib/fetchParams.js. The manipulation leads to improper handling of extra parameters. It is possible to initiate the attack remotely. Upgrading to version 1.0.0 is able to address this issue. The identifier of the patch is db94f7391ad0a16dcfcba8b9be1af385b25c42db. It is recommended to upgrade the affected component. The identifier VDB-217149 was assigned to this vulnerability.
Affected products
- flitto express-param: before 1.0.0 — fixed in 1.0.0
How to fix
Upgrade to a fixed version: flitto express-param 1.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/flitto/express-param/commit/db94f7391ad0a16dcfcba8b9be1af385b25c42db
- https://github.com/flitto/express-param/pull/19
- https://github.com/flitto/express-param/releases/tag/1.0.0
- https://vuldb.com/?ctiid.217149
- https://vuldb.com/?id.217149
- https://github.com/flitto/express-param/commit/db94f7391ad0a16dcfcba8b9be1af385b25c42db
- https://github.com/flitto/express-param/pull/19
- https://github.com/flitto/express-param/releases/tag/1.0.0
- https://vuldb.com/?ctiid.217149
- https://vuldb.com/?id.217149
Get alerted when CVE-2017-20160 or the next vulnerability affects your stack