What’s Vulnerable › Vulnerabilities
CVE-2017-20175: DaSchTour matomo-mediawiki-extension Username Piwik.hooks.php cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-05 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability classified as problematic has been found in DaSchTour matomo-mediawiki-extension up to 2.4.2 on MediaWiki. This affects an unknown part of the file Piwik.hooks.php of the component Username Handler. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 2.4.3 is able to address this issue. The patch is named 681324e4f518a8af4bd1f93867074c728eb9923d. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220203.
Affected products
- DaSchTour matomo-mediawiki-extension: from 2.4.0 before 2.4.3 — fixed in 2.4.3
How to fix
Upgrade to a fixed version: DaSchTour matomo-mediawiki-extension 2.4.3. Check the vendor advisory for mitigations.
References
- https://github.com/DaSchTour/matomo-mediawiki-extension/commit/681324e4f518a8af4bd1f93867074c728eb9923d
- https://github.com/DaSchTour/matomo-mediawiki-extension/pull/17
- https://github.com/DaSchTour/matomo-mediawiki-extension/releases/tag/v2.4.3
- https://vuldb.com/?ctiid.220203
- https://vuldb.com/?id.220203
- https://github.com/DaSchTour/matomo-mediawiki-extension/commit/681324e4f518a8af4bd1f93867074c728eb9923d
- https://github.com/DaSchTour/matomo-mediawiki-extension/pull/17
- https://github.com/DaSchTour/matomo-mediawiki-extension/releases/tag/v2.4.3
- https://vuldb.com/?ctiid.220203
- https://vuldb.com/?id.220203
Get alerted when CVE-2017-20175 or the next vulnerability affects your stack