What’s Vulnerable › Vulnerabilities
CVE-2017-20181: hgzojer Vocable Trainer VocableTrainerProvider.java path traversal
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-07 · updated 2026-06-17
- Weakness: CWE-22
Description
A vulnerability classified as critical was found in hgzojer Vocable Trainer up to 1.3.0 on Android. This vulnerability affects unknown code of the file src/at/hgz/vocabletrainer/VocableTrainerProvider.java. The manipulation leads to path traversal. Attacking locally is a requirement. Upgrading to version 1.3.1 is able to address this issue. The name of the patch is accf6838078f8eb105cfc7865aba5c705fb68426. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-222328.
Affected products
- hgzojer Vocable Trainer: before 1.3.1 — fixed in 1.3.1
How to fix
Upgrade to a fixed version: hgzojer Vocable Trainer 1.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/hgzojer/vocabletrainer/commit/accf6838078f8eb105cfc7865aba5c705fb68426
- https://github.com/hgzojer/vocabletrainer/releases/tag/v1.3.1
- https://vuldb.com/?ctiid.222328
- https://vuldb.com/?id.222328
- https://github.com/hgzojer/vocabletrainer/commit/accf6838078f8eb105cfc7865aba5c705fb68426
- https://github.com/hgzojer/vocabletrainer/releases/tag/v1.3.1
- https://vuldb.com/?ctiid.222328
- https://vuldb.com/?id.222328
Get alerted when CVE-2017-20181 or the next vulnerability affects your stack