What’s Vulnerable › Vulnerabilities
CVE-2017-20183: External Media without Import Plugin external-media-without-import.php print_media_new_panel cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-05 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability was found in External Media without Import Plugin up to 1.0.0 on WordPress. It has been declared as problematic. This vulnerability affects the function print_media_new_panel of the file external-media-without-import.php. The manipulation of the argument url/error/width/height/mime-type leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 1.0.1 is able to address this issue. The patch is identified as 9d2ecd159a6e2e3f710b4f1c28e2714f66502746. It is recommended to upgrade the affected component. VDB-227950 is the identifier assigned to this vulnerability.
Affected products
- External Media without Import: through 1.0.0
References
- https://github.com/zzxiang/external-media-without-import/commit/9d2ecd159a6e2e3f710b4f1c28e2714f66502746
- https://github.com/zzxiang/external-media-without-import/releases/tag/v1.0.1
- https://vuldb.com/?ctiid.227950
- https://vuldb.com/?id.227950
- https://github.com/zzxiang/external-media-without-import/commit/9d2ecd159a6e2e3f710b4f1c28e2714f66502746
- https://github.com/zzxiang/external-media-without-import/releases/tag/v1.0.1
- https://vuldb.com/?ctiid.227950
- https://vuldb.com/?id.227950
Get alerted when CVE-2017-20183 or the next vulnerability affects your stack