What’s Vulnerable › Vulnerabilities
CVE-2017-20189
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-22 · updated 2026-06-17
- Weakness: CWE-502
Description
In Clojure before 1.9.0, classes can be used to construct a serialized object that executes arbitrary code upon deserialization. This is relevant if a server deserializes untrusted objects.
Affected products
- Clojure: before 1.9.0 — fixed in 1.9.0
How to fix
Upgrade to a fixed version: Clojure 1.9.0. Check the vendor advisory for mitigations.
References
- https://clojure.atlassian.net/browse/CLJ-2204
- https://github.com/clojure/clojure/commit/271674c9b484d798484d134a5ac40a6df15d3ac3
- https://github.com/frohoff/ysoserial/pull/68/files
- https://hackmd.io/%40fe1w0/HyefvRQKp
- https://security.snyk.io/vuln/SNYK-JAVA-ORGCLOJURE-5740378
- https://clojure.atlassian.net/browse/CLJ-2204
- https://github.com/clojure/clojure/commit/271674c9b484d798484d134a5ac40a6df15d3ac3
- https://github.com/frohoff/ysoserial/pull/68/files
- https://hackmd.io/%40fe1w0/HyefvRQKp
- https://security.netapp.com/advisory/ntap-20241108-0002/
- https://security.snyk.io/vuln/SNYK-JAVA-ORGCLOJURE-5740378
Get alerted when CVE-2017-20189 or the next vulnerability affects your stack