What’s Vulnerable › Vulnerabilities
CVE-2017-20192: Formidable Form Builder < 2.05.03 - Unauthenticated Stored Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The Formidable Form Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via multiple parameters submitted during form entries like 'after_html' in versions before 2.05.03 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts that execute in a victim's browser.
Affected products
- strategy11team Formidable Forms – Contact Form Plugin, Survey, Quiz, Payment, Calculator Form & Custom Form Builder: before 2.05.03 — fixed in 2.05.03
How to fix
Upgrade to a fixed version: strategy11team Formidable Forms – Contact Form Plugin, Survey, Quiz, Payment, Calculator Form & Custom Form Builder 2.05.03. Check the vendor advisory for mitigations.
References
- https://klikki.fi/adv/formidable.html
- https://wordpress.org/plugins/formidable/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/900fcaab-2424-4ae8-af18-95659db0dbe3?source=cve
Get alerted when CVE-2017-20192 or the next vulnerability affects your stack