What’s Vulnerable › Vulnerabilities
CVE-2017-20208: RegistrationMagic - Custom Registration Forms <= 3.7.9.2 - PHP Object Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-18 · updated 2026-06-17
- Weakness: CWE-502
Description
The RegistrationMagic – Custom Registration Forms, User Registration, Payment, and User Login plugin for WordPress is vulnerable to PHP Object Injection in all versions up to 3.7.9.3 (exclusive) via deserialization of untrusted input from the is_expired_by_date() function. This makes it possible for unauthenticated attackers to inject a PHP Object. The additional presence of a POP chain allows attackers to fetch a remote file and install it on the site.
Affected products
- Metagauss RegistrationMagic: before 3.7.9.3 — fixed in 3.7.9.3
How to fix
Upgrade to a fixed version: Metagauss RegistrationMagic 3.7.9.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/1733274/custom-registration-form-builder-with-submission-manager
- https://www.wordfence.com/blog/2017/10/3-zero-day-plugin-vulnerabilities-exploited-wild/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c2b79193-f8fc-4ea2-8973-fe292cfb926b?source=cve
Get alerted when CVE-2017-20208 or the next vulnerability affects your stack