What’s Vulnerable › Vulnerabilities
CVE-2017-20240: Crypt::PBKDF2 versions before 0.261630 for Perl are vulnerable to timing attacks
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-12 · updated 2026-06-17
- Weakness: CWE-208
Description
Crypt::PBKDF2 versions before 0.261630 for Perl are vulnerable to timing attacks. These versions use Perl's built-in eq comparison. Discrepancies in timing could be used to guess the underlying derived-key.
Affected products
- ARODLAND Crypt::PBKDF2: before 0.261630 — fixed in 0.261630
How to fix
Upgrade to a fixed version: ARODLAND Crypt::PBKDF2 0.261630. Check the vendor advisory for mitigations.
References
- https://github.com/arodland/Crypt-PBKDF2/pull/6
- https://metacpan.org/release/ARODLAND/Crypt-PBKDF2-0.161520/source/lib/Crypt/PBKDF2.pm#L123-148
- https://metacpan.org/release/ARODLAND/Crypt-PBKDF2-0.261630/changes
- http://www.openwall.com/lists/oss-security/2026/06/12/3
Get alerted when CVE-2017-20240 or the next vulnerability affects your stack