What’s Vulnerable › Vulnerabilities
CVE-2017-20251: WordPress Insert PHP Plugin 4.7.0 PHP Code Injection via REST API
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-09 · updated 2026-07-21
- Weakness: CWE-94
Description
WordPress Insert PHP plugin versions before 3.3.1 contain a PHP code injection vulnerability that allows unauthenticated attackers to execute arbitrary PHP code by injecting malicious shortcodes through the WordPress REST API. Attackers can send POST requests to the wp-json/wp/v2/posts endpoint with crafted content containing insert_php shortcodes to include and execute remote PHP files on the server.
Affected products
- Themeisle Woody Code Snippets: before 3.3.1 — fixed in 3.3.1
How to fix
Upgrade to a fixed version: Themeisle Woody Code Snippets 3.3.1. Check the vendor advisory for mitigations.
References
- https://fr.wordpress.org/plugins/insert-php/
- https://www.exploit-db.com/exploits/41308
- https://www.vulncheck.com/advisories/wordpress-insert-php-plugin-php-code-injection-via-rest-api
Get alerted when CVE-2017-20251 or the next vulnerability affects your stack